This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Nov 24, 2025 - 15:04 UTC
Update
Version 1.18.2 of the GitHub Codespaces VSCode extension has been released. This version should resolve the connection issues, and we are continuing to monitor success rate for Codespaces creation.
Posted Nov 24, 2025 - 14:26 UTC
Update
We are testing a new version of the GitHub Codespaces VSCode extension that should resolve the connection issues, and expect that to be available in the next 30 minutes.
Posted Nov 24, 2025 - 14:00 UTC
Update
Codespaces is experiencing degraded performance. We are continuing to investigate.
Posted Nov 24, 2025 - 13:26 UTC
Update
We are seeing Codespaces connection issues related to the latest version of the VSCode Codespaces extension (1.18.1). Users can select the 1.18.0 version of the extension to avoid issues (View -> Command Palette, run "Extensions: Install specific version of Extension..."), while we work to remove the affected version.