GitHub header

Incident with Pull Requests /pulls

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Mar 02, 2026 - 22:04 UTC

Update

The issue on https://github.com/pulls is now fully resolved. All tabs are working again.
Posted Mar 02, 2026 - 22:04 UTC

Update

We're deploying a fix for pull request filtering. Full rollout across all regions is expected within 60 minutes.
Posted Mar 02, 2026 - 21:04 UTC

Update

We are experiencing issues with the Pull Requests dashboard that prevent users from filtering their pull requests. We have identified a mitigation and are deploying a fix. We'll post another update by 21:00 UTC.
Posted Mar 02, 2026 - 20:02 UTC

Update

We are seeing a degraded experience when attempting to filter the /pulls dashboard. We are working on a mitigation.
Posted Mar 02, 2026 - 19:23 UTC

Investigating

We are investigating reports of degraded performance for Pull Requests
Posted Mar 02, 2026 - 19:11 UTC
This incident affected: Pull Requests.