GitHub header

Disruption with some GitHub services

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Apr 27, 2026 - 19:02 UTC

Monitoring

The degradation has been mitigated. We are monitoring to ensure stability.
Posted Apr 27, 2026 - 19:01 UTC

Update

We've found the issue and are working on deploying a solution to get Codex agent runs working again.
Posted Apr 27, 2026 - 17:26 UTC

Update

Copilot Cloud Agent (CCA) jobs using the Codex agent are failing after starting. To avoid this issue, please choose a different agent. We are investigating the cause and working towards remediation
Posted Apr 27, 2026 - 17:01 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Apr 27, 2026 - 16:48 UTC