GitHub header
Incident with GitHub Actions and Codespaces
Incident Report for GitHub
Resolved
This incident has been resolved.
Posted Apr 14, 2022 - 01:28 UTC
Update
Actions and Codespaces are operating normally except for incorrect billing reports. We have started a cleanup of incorrect billing information and expect that to be completed in a few hours.
Posted Apr 13, 2022 - 23:36 UTC
Update
We've applied a mitigation to unblock running Actions jobs and using Codespaces. We are currently working on addressing the inconsistencies in billing information.
Posted Apr 13, 2022 - 21:07 UTC
Update
We are investigating reports of users mistakenly seeing notifications that they've hit their billing limits for Actions and Codespaces.
Posted Apr 13, 2022 - 20:50 UTC
Update
Codespaces is experiencing degraded performance. We are still investigating and will provide an update when we have one.
Posted Apr 13, 2022 - 20:40 UTC
Investigating
We are investigating reports of degraded performance for GitHub Actions.
Posted Apr 13, 2022 - 20:35 UTC
This incident affected: GitHub Actions.