GitHub header
Incident with Actions
Incident Report for GitHub
Resolved
On Wednesday February 21, 2024, 17:07 UTC, we deployed a configuration change to one of our services inside of Actions. At 17:14 UTC we noticed an increase in exceptions that impacted approximately 85% of runs at that time.

At 17:18 UTC, we reverted the deployment and our service immediately recovered. During this timeframe, customers may have noticed their workflows failed to trigger or workflows were queued but did not progress.

To prevent this issue in the future we are improving our deployment observability tooling to detect errors earlier in the deployment pipeline.
Posted Feb 21, 2024 - 17:30 UTC
Investigating
We are investigating reports of degraded performance for Actions
Posted Feb 21, 2024 - 17:20 UTC
This incident affected: Actions.