GitHub header

Incident with Actions, API Requests and Pages

Incident Report for GitHub

Resolved

This incident has been resolved.
Posted Jun 29, 2023 - 06:43 UTC

Update

With the fix deployed, we are now seeing recovery across impacted scenarios.
Posted Jun 29, 2023 - 06:41 UTC

Update

We are continuing to rollout the fix for failing Actions jobs using the deployment environments feature. We are expecting the remaining rollout to take another hour
Posted Jun 29, 2023 - 06:05 UTC

Update

We are continuing to monitor the rollout of the fix for failing Actions jobs using the deployment environments feature. We are expecting the rollout to take up to another hour
Posted Jun 29, 2023 - 05:24 UTC

Update

We are continuing to monitor the rollout of the fix for failing Actions jobs using the deployment environments feature. We are expecting the rollout to take up to another 1 to 1.5 hours.
Posted Jun 29, 2023 - 04:54 UTC

Update

We are continuing to monitor the rollout of the fix for failing Actions jobs using the deployment environments feature. We are expecting the rollout to take up to 1.5 to 2 hours.
Posted Jun 29, 2023 - 04:19 UTC

Update

We are monitoring the rollout of a fix for failing Actions jobs using the deployment environments feature. We are expecting the rollout to take a couple more hours.
Posted Jun 29, 2023 - 03:32 UTC

Update

We are monitoring the rollout of a fix for failing Actions jobs using environments. The impact on GitHub Pages publishing continues.
Posted Jun 29, 2023 - 03:12 UTC

Update

The fix for failing Actions jobs using environments is rolling out. We are expecting the rollout to take several hours to complete. The impact on GitHub Pages continues.
Posted Jun 29, 2023 - 02:50 UTC

Update

The fix for failing Actions jobs using environments is rolling out. We are expecting the rollout to take several hours to complete.
Posted Jun 29, 2023 - 02:02 UTC

Update

We are deploying a fix for failing Actions jobs using environments. The issue is also impacting GitHub Pages - deployments are pending in an approval stage.
Posted Jun 29, 2023 - 01:26 UTC

Update

We continue working on a fix for failing Actions jobs using environments.
Posted Jun 29, 2023 - 00:37 UTC

Update

We now understand the root cause of failing Actions jobs using environments. We are working on a fix.
Posted Jun 29, 2023 - 00:11 UTC

Update

We are seeing failures in Actions jobs using environments. Downstream impact on the deployments of GitHub Pages. We are investigating more details.
Posted Jun 28, 2023 - 23:39 UTC

Update

API Requests is operating normally.
Posted Jun 28, 2023 - 23:35 UTC

Update

Pages is experiencing degraded performance. We are continuing to investigate.
Posted Jun 28, 2023 - 23:15 UTC

Update

Actions is experiencing degraded performance. We are continuing to investigate.
Posted Jun 28, 2023 - 23:11 UTC

Update

Actions is operating normally.
Posted Jun 28, 2023 - 23:01 UTC

Investigating

We are investigating reports of degraded performance for Actions and API Requests.
Posted Jun 28, 2023 - 22:59 UTC
This incident affected: API Requests, Actions, and Pages.