GitHub header

Incomplete pull request results in repositories

Incident Report for GitHub

Update

We are actively reindexing the remaining ElasticSearch indexes. Our priority is ensuring correctness and avoiding further impact.  We are taking a measured approach to safely backfill data and will share additional updates as progress continues.
Posted Apr 28, 2026 - 15:58 UTC

Update

After yesterday’s incident, we are investigating cases where /pulls and /repo/pulls pages are not showing all indexed pull requests. This is because our Elasticsearch cluster does not currently contain all indexed documents.

No pull request data has been lost. As pull requests are updated, they will be reindexed. We are also working on accelerating a full reindex so these pages return complete results again.
Posted Apr 28, 2026 - 14:51 UTC

Investigating

We are investigating reports of degraded performance for Pull Requests
Posted Apr 28, 2026 - 14:17 UTC
This incident affects: Pull Requests.