GitHub header
Incident with Actions
Incident Report for GitHub
Resolved
On April 9, 2024, between 18:00 and 20:17 UTC, Actions was degraded and had failures for new and existing customers. During this time, Actions failed to start for 5,426 new repositories, and 1% of runs for existing customers were delayed, with half of those failing due to an infrastructure error.

The root cause was an expired certificate which caused authentication to fail between internal services. The incident was mitigated once the cert was rotated.

We are working to improve our automation to ensure certs are rotated before expiration.
Posted Apr 09, 2024 - 20:17 UTC
Update
We continue to work to resolve issues with repositories not being able to enable Actions and Actions network configuration setup not working properly. We have confirmed a fix and are in the process of deploying it to production. Another update will be shared within the next 30 minutes.
Posted Apr 09, 2024 - 19:43 UTC
Update
We continue to work to resolve issues with repositories not being able to enable Actions and Actions network configuration setup not working properly. We will provide additional information shortly.
Posted Apr 09, 2024 - 19:06 UTC
Update
We are aware of issues with repositories not being able to enable Actions. We are in the process of restoring full functionality and will provide additional information shortly.
Posted Apr 09, 2024 - 18:36 UTC
Investigating
We are investigating reports of degraded performance for Actions
Posted Apr 09, 2024 - 18:36 UTC
This incident affected: Actions.