We identified and addressed failures in two proxy servers and applied mitigation. Since then, timeouts have ceased, and we are considering the incident resolved. We will continue to monitor the situation closely and provide updates if any changes occur.
Posted Nov 28, 2024 - 05:10 UTC
Update
We are investigating some network proxy issues that may be contributing to the timeouts in a small percentage of requests in Codespaces. We will continue to investigate.
Posted Nov 28, 2024 - 04:34 UTC
Update
We are continuing to investigate issues with timeouts in a small percentage of requests in Codespaces. We will update you on mitigation progress.
Posted Nov 28, 2024 - 04:03 UTC
Update
We are investigating issues with timeouts in some requests in Codespaces. Some users may not be able to connect to their Codespaces at this time. We will update you on mitigation progress.
Posted Nov 28, 2024 - 03:32 UTC
Investigating
We are investigating reports of degraded performance for Codespaces