On June 17, 2025, between 19:32 UTC and 20:03 UTC, a routing policy deployment to a subset of network devices caused reachability issues for certain prefixes. The change passed review, but gaps in validation, resulted in unintended configuration changes being deployed to production. We declared an incident after confirming the issue was not localized and was impacting multiple applications. The deployment was rolled back, and reachability was restored within 27 minutes. To prevent similar issues, we are expanding our validation processes to include increasing test coverage for routing policy changes.
Posted Jun 17, 2025 - 20:22 UTC
Update
Actions is operating normally.
Posted Jun 17, 2025 - 20:15 UTC
Update
Codespaces is experiencing degraded performance. We are continuing to investigate.
Posted Jun 17, 2025 - 20:14 UTC
Update
Webhooks is operating normally.
Posted Jun 17, 2025 - 20:13 UTC
Update
Pull Requests is operating normally.
Posted Jun 17, 2025 - 20:12 UTC
Update
API Requests is operating normally.
Posted Jun 17, 2025 - 20:10 UTC
Update
Issues is operating normally.
Posted Jun 17, 2025 - 20:06 UTC
Update
API Requests is experiencing degraded performance. We are continuing to investigate.
Posted Jun 17, 2025 - 20:05 UTC
Update
We experienced problems with multiple services, causing disruptions for some users. We have identified the cause and are rolling out changes to restore normal service. Many services are recovering, but full recovery is ongoing.
Posted Jun 17, 2025 - 20:04 UTC
Update
Copilot is operating normally.
Posted Jun 17, 2025 - 20:04 UTC
Update
Pages is operating normally.
Posted Jun 17, 2025 - 20:03 UTC
Update
Pull Requests is experiencing degraded performance. We are continuing to investigate.
Posted Jun 17, 2025 - 20:01 UTC
Update
Pull Requests is experiencing degraded availability. We are continuing to investigate.
Posted Jun 17, 2025 - 19:55 UTC
Update
Copilot is experiencing degraded performance. We are continuing to investigate.
Posted Jun 17, 2025 - 19:55 UTC
Update
Actions is experiencing degraded performance. We are continuing to investigate.
Posted Jun 17, 2025 - 19:54 UTC
Update
Webhooks is experiencing degraded performance. We are continuing to investigate.
Posted Jun 17, 2025 - 19:54 UTC
Update
API Requests is experiencing degraded availability. We are continuing to investigate.
Posted Jun 17, 2025 - 19:53 UTC
Update
We are investigating reports of issues with many services impacting segments of customers. We will continue to keep users updated on progress towards mitigation.
Posted Jun 17, 2025 - 19:53 UTC
Update
API Requests is experiencing degraded performance. We are continuing to investigate.
Posted Jun 17, 2025 - 19:51 UTC
Update
Pages is experiencing degraded performance. We are continuing to investigate.
Posted Jun 17, 2025 - 19:49 UTC
Update
Copilot is experiencing degraded availability. We are continuing to investigate.
Posted Jun 17, 2025 - 19:49 UTC
Update
Issues is experiencing degraded performance. We are continuing to investigate.
Posted Jun 17, 2025 - 19:47 UTC
Investigating
We are investigating reports of degraded performance for Copilot
Posted Jun 17, 2025 - 19:42 UTC
This incident affected: Webhooks, API Requests, Issues, Pull Requests, Actions, Pages, Codespaces, and Copilot.