This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Jul 24, 2026 - 17:36 UTC
Update
We are seeing recovery across all services
Posted Jul 24, 2026 - 17:24 UTC
Update
The degradation affecting API Requests, Actions, Copilot, Issues, Pages and Pull Requests has been mitigated. We are monitoring to ensure stability.
Posted Jul 24, 2026 - 17:16 UTC
Update
Actions is experiencing degraded performance. We are continuing to investigate.
Posted Jul 24, 2026 - 16:41 UTC
Update
We have applied a mitigation and are monitoring for recovery
Posted Jul 24, 2026 - 16:40 UTC
Update
Actions is experiencing degraded availability. We are continuing to investigate.
Posted Jul 24, 2026 - 16:28 UTC
Update
Pages is experiencing degraded performance. We are continuing to investigate.
Posted Jul 24, 2026 - 16:27 UTC
Update
Copilot is experiencing degraded performance. We are continuing to investigate.
Posted Jul 24, 2026 - 16:26 UTC
Update
We are investigating timeouts to some GitHub services
Posted Jul 24, 2026 - 16:22 UTC
Update
Pull Requests is experiencing degraded performance. We are continuing to investigate.
Posted Jul 24, 2026 - 16:20 UTC
Update
Actions is experiencing degraded performance. We are continuing to investigate.
Posted Jul 24, 2026 - 16:19 UTC
Investigating
We are investigating reports of degraded performance for API Requests and Issues
Posted Jul 24, 2026 - 16:17 UTC
This incident affected: API Requests, Issues, Pull Requests, Actions, Pages, and Copilot.