GitHub header

macos-15-arm64 hosted runner queue delays

Incident Report for GitHub

Resolved

On March 18, between 13:04 and 16:55 UTC, Actions workflows relying on hosted runners using the beta MacOS 15 image experienced increased queue time waiting for available runners. An image update was pushed the previous day that included a performance reduction. The slower performance caused longer average runtimes, exhausting our available Mac capacity for this image. This was mitigated by rolling back the image update. We have updated our capacity allocation to the beta and other Mac images and are improving monitoring in our canary environments to catch this potential issue before it impacts customers.
Posted Mar 18, 2025 - 17:15 UTC

Update

We are seeing improvements in telemetry and are monitoring for full recovery.
Posted Mar 18, 2025 - 16:56 UTC

Update

We've applied a mitigation to fix the issues with queuing Actions jobs on macos-15-arm64 Hosted runner. We are monitoring.
Posted Mar 18, 2025 - 16:36 UTC

Update

The team continues to investigate issues with some Actions macos-15-arm64 Hosted jobs being queued for up to 15 minutes. We will continue providing updates on the progress towards mitigation.
Posted Mar 18, 2025 - 15:43 UTC

Investigating

We are currently investigating this issue.
Posted Mar 18, 2025 - 15:05 UTC