GitHub header

Incident with CodeQL

Incident Report for GitHub

Update

Webhooks is experiencing degraded performance. We are continuing to investigate.
Posted May 12, 2026 - 15:44 UTC

Update

We're continuing to investigate issues with CodeQL actions workflows. We're additionally seeing delays for notifications, webhooks, and the Slack integration.
Posted May 12, 2026 - 15:42 UTC

Update

CodeQL actions are currently experiencing delays, which may result in those actions being stuck in a pending state or having failed due to a timeout.
Posted May 12, 2026 - 15:13 UTC

Investigating

We are investigating reports of degraded performance for CodeQL
Posted May 12, 2026 - 14:38 UTC
This incident affects: Webhooks and Actions.