GitHub header

Extended job start delays for larger hosted runners

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Feb 20, 2026 - 20:41 UTC

Update

The team continues to investigate issues with some larger runner jobs being queued for a long time. We are though seeing improvement in the queue times. We will continue providing updates on the progress towards mitigation.
Posted Feb 20, 2026 - 20:36 UTC

Update

We are investigating reports of degraded performance for Larger Hosted Runners
Posted Feb 20, 2026 - 20:01 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Feb 20, 2026 - 20:00 UTC