GitHub header

Disruption with some GitHub services

Incident Report for GitHub

Resolved

On 7/3/2025, between 5:21:17 AM and 7:11:49 AM UTC, customers were prevented from SSO authorizing Personal Access Tokens and SSH keys via the GitHub UI. Approximately 1300 users were impacted.

A code change modified the content type of the response returned by the server, causing a lazily-loaded dropdown to fail to render, prohibiting the user from proceeding to authorize. No authorization systems were impacted during the incident, only the UI component. We mitigated the incident by reverting the code change that introduced the problem.

We are making improvements to our release process and test coverage to catch this class of error earlier in our deployment pipeline. Further, we are improving monitoring to reduce our time to detection and mitigation of issues like this one in the future.
Posted Jul 03, 2025 - 07:12 UTC

Update

The rollback has been deployed successfully on all environments. Customers should now be able to SSO authorize their Classic Personal Access Tokens and SSH keys on their GitHub organizations.
Posted Jul 03, 2025 - 07:11 UTC

Update

The root cause for the rendering bug that prevented customers from SSO authorizing Personal Access Tokens and SSH keys has started rolling out. We are continuously monitoring this rollback.
Posted Jul 03, 2025 - 06:46 UTC

Update

We have identified the root cause for the rendering bug that prevented customers from SSO authorizing Personal Access Tokens and SSH keys.The changes that caused the issue are being rolled back.
Posted Jul 03, 2025 - 06:07 UTC

Update

We are investigating an issue with SSO authorizing Classic Personal Access Tokens and SSH keys.
Posted Jul 03, 2025 - 05:45 UTC

Investigating

We are currently investigating this issue.
Posted Jul 03, 2025 - 05:39 UTC