GitHub header

Some Actions customers experiencing run start delays

Incident Report for GitHub

Resolved

On December 10, 2025 between 08:50 UTC and 11:00 UTC, some GitHub Actions workflow runs experienced longer-than-normal wait times for jobs starting or completing. All jobs successfully completed despite the delays. At peak impact, approximately 8% of workflow runs were affected.

During this incident, some nodes received a spike in workflow events that led to queuing of event processing. Because runs are pinned to nodes, runs being processed by these nodes saw delays in starting or showing as completed. The team was alerted to this at 8:58 UTC. Impacted nodes were disabled from processing new jobs to allow queues to drain.

We have increased overall processing capacity and are implementing safeguards to better balance load across all nodes when spikes occur. This is important to ensure our available capacity can always be fully utilized.
Posted Dec 10, 2025 - 11:05 UTC

Update

Actions is operating normally.
Posted Dec 10, 2025 - 11:05 UTC

Update

We have validated the mitigation and are no longer seeing impact.
Posted Dec 10, 2025 - 11:05 UTC

Update

We are seeing improvements in telemetry and are monitoring for full recovery.
Posted Dec 10, 2025 - 10:58 UTC

Update

We've applied a mitigation to fix the issues with queuing and running Actions jobs. We will continue monitoring to confirm whether this resolves the issue.
Posted Dec 10, 2025 - 10:25 UTC

Update

The team continues to investigate issues with some Actions jobs being queued for a long time. We will continue providing updates on the progress towards mitigation.
Posted Dec 10, 2025 - 09:41 UTC

Update

We're investigating Actions workflow runs taking longer than expected to start.
Posted Dec 10, 2025 - 09:13 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Dec 10, 2025 - 09:11 UTC
This incident affected: Actions.