GitHub header
Degraded performance for some Copilot users
Incident Report for GitHub
Resolved
Between September 25, 2024, 22:20 UTC and September 26, 2024, 5:00 UTC the Copilot service was degraded. During this time Copilot chat requests failed at an average rate of 15%.

This was due to a faulty deployment in a service provider that caused server errors from multiple regions. Traffic was routed away from those regions at 22:28 UTC and 23:39 UTC, which partially restored functionality, while the upstream service provider rolled back their change. The rollback was completed at 04:41 UTC.

We are continuing to improve our ability to respond more quickly to similar issues through faster regional redirection and working with our upstream provider on improved monitoring.
Posted Sep 26, 2024 - 05:08 UTC
Update
Monitors continue to see improvements. We are declaring full recovery.
Posted Sep 26, 2024 - 05:08 UTC
Update
Copilot is operating normally.
Posted Sep 26, 2024 - 05:03 UTC
Update
We've applied a mitigation to fix the issues and are seeing improvements in telemetry. We are monitoring for full recovery.
Posted Sep 26, 2024 - 03:51 UTC
Update
We believe we have identified the root cause of the issue and are monitoring to ensure the problem does not recur.
Posted Sep 26, 2024 - 02:34 UTC
Update
We are continuing to investigate the root cause of the latency previously observed to ensure there is no reoccurrence, and better stability going forward.
Posted Sep 26, 2024 - 01:46 UTC
Update
We are continuing to investigate the root cause of the latency previously observed to ensure there is no reoccurrence, and better stability going forward.
Posted Sep 26, 2024 - 01:03 UTC
Update
Copilot users should no longer see request failures. We are still investigating the root cause of the issue to ensure that the experience will remain uninterrupted.
Posted Sep 26, 2024 - 00:29 UTC
Update
We are seeing recovery for requests to Copilot API in affected regions, and are continuing to investigate to ensure the experience remains stable.
Posted Sep 25, 2024 - 23:55 UTC
Update
We have noticed a degradation in performance of Copilot API in some regions. This may result in latency or failed responses to requests to Copilot. We are investigating mitigation options.
Posted Sep 25, 2024 - 23:40 UTC
Investigating
We are investigating reports of degraded performance for Copilot
Posted Sep 25, 2024 - 23:39 UTC
This incident affected: Copilot.