GitHub header

Latency issues across a number of services

Incident Report for GitHub

Update

The degradation affecting Pull Requests has been mitigated. We are monitoring to ensure stability.
Posted Jul 23, 2026 - 09:27 UTC

Update

We identified the source of latency affecting multiple services and applied a fix. Issues and Actions are recovering, and remaining affected services are seeing improvement as processing backlogs clear. We are actively monitoring recovery across all services.
Posted Jul 23, 2026 - 09:22 UTC

Update

The degradation affecting Actions has been mitigated. We are monitoring to ensure stability.
Posted Jul 23, 2026 - 09:19 UTC

Update

The degradation affecting Issues has been mitigated. We are monitoring to ensure stability.
Posted Jul 23, 2026 - 09:18 UTC

Update

We're currently investigating latency across multiple services. This can show as Actions jobs taking longer to start, Issues search serving stale results, and other listed services being similarly impacted.
Posted Jul 23, 2026 - 08:34 UTC

Update

Pull Requests is experiencing degraded performance. We are continuing to investigate.
Posted Jul 23, 2026 - 08:25 UTC

Investigating

We are investigating reports of degraded availability for Actions, Issues and Webhooks
Posted Jul 23, 2026 - 07:53 UTC
This incident affects: Webhooks, Issues, Pull Requests, and Actions.