GitHub header

Copilot Coding Agent failing to start some jobs

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Apr 02, 2026 - 16:30 UTC

Update

When assigning tasks to Copilot Cloud Agent, the task will appear to be working, but may not actually be running.

We are investigating.
Posted Apr 02, 2026 - 16:28 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Apr 02, 2026 - 16:18 UTC